Sujet : Blackberry Link : rien ne va plus ?

Bonjour à tous,

J'utilise un BB Q10 et j'ai installé il y a quelques temps déjà Blackberry Link sur mon MacBook Pro sous 10.8.5 (Mountain Lion).
Je n'avais jusqu'ici pas trop de problème, je me limitais à faire des sauvegardes de mon Q10 de temps en temps.

Mon Q10, justement, accumule les bugs, et j'en ai acheté un second d'occasion pour prendre le relais.

Premier problème :
La sauvegarde du Q10 de départ connecté via USB ne marchait pas., J'ai dû changer de port USB. Pour une raison que j'ignore, le port de départ semblait incompatible (alors qu'il fonctionne parfaitement par ailleurs).
Mais bon, via le second port, la sauvegarde est faite finalement.

Deuxième problème :
Je branche le second Q10. Link me dit que l'OS est à jour. Je voulais changer et personnaliser le nom de ce nouveau téléphone.
Je le change, le nouveau nom apparait dans Link. MAIS : je débranche ce Q10 et le rebranche : le nouveau nom a disparu et a été remplacé par l'ancien.

Troisième problème :
Je voulais aussi charger les contacts issus de la sauvegarde du premier Q10. Je connecte le second Q10 avec son ancien-nom et je tente la restauration des contacts à partir de la sauvegarde de tout à l'heure. (soit dit en passant, la restauration des contacts seuls est apparemment impossible, il faut aussi restaurer les réglages en même temps ...).
Et là, ça ne marche pas ....

Tout ça pour dire que je suis bloqué à bien des étapes, et que l'utilisation de mes Q10 est au point mort ...

Sauriez-vous SVP me faire part de vos expériences dans le même genre ?
Des idées de solutions ?
Dois-je migrer vers Link version PC ?

Merci d'avance,
Bien cordialement.