1 Dernière modification par antoine.souchet (28-01-2015 12:28:41)

Sujet : Forcer compatibilité .apk Lucky Patcher

Hello, lequel d'entre vous n'a jamais été frustré de ne pas pouvoir installer son application Android sur son magnifique Blackberry ?

Dans cet optique, j'ai trouvé un .apk qui permet d'avoir un peu plus de "chance" d'installer son application.
Il s'agit de Lucky Patcher.

Dans l’exemple ci-dessous on va essayer d'installer l'apk du crédit mutuel.
Si vous tentez une installation "normal" l'application s’installer mais ne se lancera pas (service google obligatoire, géolocalisation qui explose tout etc).

Attention j'ai testé tout ça uniquement avec une version 10.2 !

Donc premiére chose à faire installer Lucky Patcher.
10.2 : Lucky Patcher 4.4.4
https://app.box.com/s/03duusrsm0k13yc7xjxp

10.3 : Lucky Patcher  5.4.3
https://drive.bitcasa.com/send/ZQwEDzUH … B9hhgh95qa

Pour les utilisateurs 10.2 dire NON à la demande de mise à jour (l'application ne fonctionnera plus sinon)

On télécharge, on installe et on lance l'application.
Ensuite on clique sur Reconstruire/installer

http://image.noelshack.com/fichiers/2015/05/1422440477-capture.png

Aprés on rechercher l'apk qui ne veut pas s'installer (dans notre cas l'apk du crédit mutuel).
On clique sur Reconstruction
http://image.noelshack.com/fichiers/2015/05/1422440477-capture3.png

Puis Apk sans vérification de licence et on coche le "Remove dependencies"

http://image.noelshack.com/fichiers/2015/05/1422440477-capture1.png
On clique ensuite sur reconstuire l'application, Lucky patcher va placer le nouvel apk dans son repertoire, on relance l'installation depuis le nouvel apk généré et la magie, ça fonctionne !

On a vu comment enlever des services, mais vous pouvez voir qu'on a un tas d'options disponible en fonction de ce qui "coince" sur l'appli qu'on souhaite installer, donc en essayant pas mal de truc on peut quasiment arriver à faire marcher l'application que l'on veut ! smile

http://www.blackberry-10.fr/forum/img/reglettes/z10.png
►   P'9982STK100-1 / 10.2.1.3442

Re : Forcer compatibilité .apk Lucky Patcher

Pas mal ! Je connaissais pas ! Je vais essayer de patcher 2 ou 3 applications APK que je n'ai jamais réussi à faire marcher. Sais-tu si le mode extrême est réellement efficace ou si c'est vraiment du cas par cas et qu'il faut tester ?

Merci pour le partage, HOP ton topic dans mes favoris pour penser à essayer dès que j'aurais un peu de temps ^^

http://img4.hostingpics.net/pics/390216popopopopopop.png

Re : Forcer compatibilité .apk Lucky Patcher

Hello,

honnêtement jamais eu besoin de tester ce mode, la suppression des services à suffit à chaque fois (Snapschat etc).
Surement à tester pour les jeux qui ne veulent pas se télécharger. smile

http://www.blackberry-10.fr/forum/img/reglettes/z10.png
►   P'9982STK100-1 / 10.2.1.3442

4 Dernière modification par Tchan (03-02-2015 19:02:29)

Re : Forcer compatibilité .apk Lucky Patcher

J'ai testé avec succés cette méthode, grand merci. Sympa de pouvoir supprimer les PUB pour certaines applications.

Petite remarque, faut supprimer l'application (Snapchat pour l'exemple) avant de la réinstaller (via l'apk qui est dans le répertoire de Lucky Patcher.) sinon on nous informe qu'elle est déjà disponible sur le tel.

Je précise que je suis sur un modèle Q10 avec comme version logiciel : 10.3.0.738

Re : Forcer compatibilité .apk Lucky Patcher

Bonsoir,
je voulais savoir si on recevait les notifications des applications android sur la 10.3.1 ?
bonne soirée

6

Re : Forcer compatibilité .apk Lucky Patcher

Bonsoir, ça dépends des applications Android certaines oui d'autres non.

BlackBerry PlayBook 16 Go.
PIN BBM : 7B1847AC
Forfait Free illimité & option 4G activée.

7 Dernière modification par Tchan (09-02-2015 19:28:26)

Re : Forcer compatibilité .apk Lucky Patcher

Une mise à jour nous est proposé, version 5.4.5
A l'installation j'ai un message d'erreur : impossible d'installer cette appli.

Des solutions svp ?

Re : Forcer compatibilité .apk Lucky Patcher

Je suis en version 10.2 sur mon Q10, si je passe en 10.3, y'a t'il plus de chance que certaines appli fonctionnent?
Car j'ai essayé de patcher l'appli e.zixtreme, pour contrôler ma camera a distance, mais rien n'y fait.

http://www.blackberry-10.fr/forum/img/reglettes/classic_black.pnghttp://www.blackberry-10.fr/forum/img/reglettes/orange.png

9

Re : Forcer compatibilité .apk Lucky Patcher

D'après les retours, oui certaines applications qui ne fonctionnaient pas en 10.2.1 fonctionnent en 10.3.1.
Le runtime android a été grandement mis à jour.
Il y a aussi quelques cas (mais c'est plus rare) d'applications qui fonctionnaient en 10.2.1 mais qui ne fonctionnement plus en 10.3.1. Normalement cela ne devrait pas être le cas.

http://www.blackberry-10.fr/forum/img/reglettes/q5_black.png http://www.blackberry-10.fr/forum/img/reglettes/orange.png
OS 10.3.2

Re : Forcer compatibilité .apk Lucky Patcher

Minus a écrit:

D'après les retours, oui certaines applications qui ne fonctionnaient pas en 10.2.1 fonctionnent en 10.3.1.
Le runtime android a été grandement mis à jour.
Il y a aussi quelques cas (mais c'est plus rare) d'applications qui fonctionnaient en 10.2.1 mais qui ne fonctionnement plus en 10.3.1. Normalement cela ne devrait pas être le cas.

Ouai, dans mon cas, pas de crainte alors. ^^

http://www.blackberry-10.fr/forum/img/reglettes/classic_black.pnghttp://www.blackberry-10.fr/forum/img/reglettes/orange.png

11

Re : Forcer compatibilité .apk Lucky Patcher

Je n'arrive pas a faire fonctionner l'application snapchat et c'est vraiment très embêtant. Vous pouvez m'aider ?? Ca m'affiche encore que j'ai besoin des services gg play.

Re : Forcer compatibilité .apk Lucky Patcher

Bon, bah maintenant que mon Q10 est en 10.3, j'ai testé l'appli e.zixtreme; mais c'est tout pareil qu'avant, elle plante au démarrage.

http://www.blackberry-10.fr/forum/img/reglettes/classic_black.pnghttp://www.blackberry-10.fr/forum/img/reglettes/orange.png

Re : Forcer compatibilité .apk Lucky Patcher

Hello les addicts !

Je clique sur le lien (10.3) mais je n'ai pas la possibilité de telecharger l'apk..

Pourtant je me suis inscrit sur le site mais rien n'y fait..

Une autre solution ?

Merci d'avance la BB family

http://www.blackberry-10.fr/forum/img/reglettes/q10.png
http://www.blackberry-10.fr/forum/img/reglettes/bouygues.png

14

Re : Forcer compatibilité .apk Lucky Patcher

Ca ne vous fait pas peur d'installer des applis à l'origine inconnue ?

http://www.blackberry-10.fr/forum/img/reglettes/q5_black.png
►  OS 10.3.2.2836   ►  SFR Red

15 Dernière modification par soulwwx (18-06-2015 20:49:33)

Re : Forcer compatibilité .apk Lucky Patcher

Fonctionne avec Chromecast mais impossible de caster quoi que ce soit hmm

Pour ce qui est de Snapchat, les dernières versions ne fonctionnent plus.
L'appli refuse de se connecter après la saisie des ID

Blackberry Z30 - STA100-2 - 10.3.1.1784